AC Question

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by Zamble, Jul 15, 2011.

  1. Zamble

    Zamble New Member

    I have a '98 Suburban, with Rear air. We tried to recharge the system today and the compressor would not engage. I unplugged the compressor and hooked it up to the battery. And it worked just fine.

    Can the sensor on the ac line prevent the compressor from engaging?

    Thanks.
     
  2. Bigg Ron

    Bigg Ron Rockstar 100 Posts

    Yes, you may have a defective lo pressure sensor, or a bad relay. Try jumping the relay, it that doesnt work then try jumping the lo pressure switch.
     
  3. pdougc

    pdougc New Member

    For those who have never done it before, what exactly is involved in jumping the relay?
     
  4. Zamble

    Zamble New Member

    The low pressure sensor has 2 connectors on the plug. At the risk of sounding stupid, what should I do to jump it?

    Thanks
     
  5. Zamble

    Zamble New Member

    Another question. To change out the low pressure switch/sensor, will I need to have my system evacuated?

    Thanks.
     
  6. Zamble

    Zamble New Member

    Anyone one know how to jump the low pressure switch?
     
  7. stephan

    stephan Rockstar 4 Years 5000 Posts

    You can take a paper clip or a piece of wire, disconnect the plug from the low pressure switch & just bridge the 2 wires in the plug.
     
  8. killbill

    killbill New Member

    I had a similar issue in my 99 suburban about two weeks ago. The cycle cutoff switch was bad. I was able to go down to Auto Zone and get a new one for $10 and fix everything. Like Stephan said, just take the plug off of the switch on the acumalator and bridge the connector with a peice of wire and see if the clutch on the compressor kicks on. If it does, you have a bad switch. You should be able to remove the switch without leaking freon.
     
  9. Zamble

    Zamble New Member

    Great thanks for the help!
     
  10. Zamble

    Zamble New Member

    Well unfortunately, when I looped the plug for the low pressure sensor, it kept popping the 10amp fuse in the engine fuse panel.

    As with before, when I wire the battery straight to the compressor it kicks on and works great. We thought the plug between the compressor and harness was bad. So we checked it with an ohm meter and it shows 12.8 volts. So I bridged the connector from the plug to the compressor and nothing.

    Why would the line coming to the compressor show 12.8ish volts but not turn the compressor on?

    Any suggestions?
     
    Last edited: Jul 18, 2011

Share This Page

Newest Gallery Photos