1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Aftermarket Head Unit

Discussion in 'Audio, Video & Gadget Tech' started by Smoker_98, Jun 10, 2009.

  1. Smoker_98

    Smoker_98 New Member

    Hi all! I am new to the forum and truck world for that matter. I just picked up a 03 Silverado Z71 ext cab. I am swapping some audio gear from my last vehicle into it, but I have hit some snags. The truck does not have the bose system or onstar, I wired the harness to the eclipse one and pluged her in and nothing. About all that would work is the the open button. I tried this with another kenwood deck as well and nothing. Obviously I have something screwed up, is there any tricks with wiring up a truck? Does anyone have any advice? Thanks!
  2. MannyO

    MannyO Member

    are you still using the converter from your other vehicle for the truck? if you are then you might need to get the proper converter kit for it.
  3. Smoker_98

    Smoker_98 New Member

    Thanks! I figured it out. The GM harness does not provide a switched 12+. You have to tap into the fuse box and run a line to the head units harness.

Share This Page