Airbag Light

Discussion in 'General Chevy & GM Tech Questions' started by ahm1127, Mar 17, 2010.

  1. ahm1127

    ahm1127 Rockstar 100 Posts

    My 05' Suburban airbag light is on so I took to GM dealer & they told me that the computer is not communicating with either sensor in front end & that I need to replace both sensors.

    Does any body know about this & would both sensors go at the same time?

    Sensors are not cheap & I was also informed that they need to reprogram computer for them to work once installed.
    Thanks

     
  2. Jimmiee

    Jimmiee Epic Member 5+ Years 1000 Posts

    I would get a second opinion on that. Each sensor should set it's own code. did they give you the codes? Take it to another GM dealer. Any GM dealer will be able to diagnose it or a good electrical repair shop can also diagnose it. It would be rare to have 2 sensors fail at once IMO.
     
  3. ahm1127

    ahm1127 Rockstar 100 Posts

    Thanks, I thought it was weird also but we dont have any/many GM dealers by me. This one is 40 minutes away thanks to GM closing them & nobody has the equipment to read computer. I figured 1 but not both!
     
  4. Loggerhead Mike

    Loggerhead Mike Rockstar 100 Posts

    check the sensor connectors. look for any corrosion and do a connector pin drag test
     
  5. ahm1127

    ahm1127 Rockstar 100 Posts

    So I had it changed on Fri, the wife uses truck & she wanted it done. I checked the plugs on Thursday & they looked good & clean so I reconnected & no difference. They gave me the old sensors so I was wondering how to check them, ohms?
    Thanks for the help!
     

Share This Page

Newest Gallery Photos