1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Another newbie

Discussion in 'Member Introductions' started by CP10KRK, Mar 23, 2013.

Random Gallery Photos

  1. CP10KRK

    CP10KRK New Member

    Hello Everyone! My name is Kevin and I live in SoCal. I finally decided to buy a truck, a 1999 GMC 1500 SLT. It's a nice truck,Green and Silver with Escalade chrome wheels. But it has a problem with the gauges, as in none of them work. The tach and speedo are good, but that's all. The gear indicator and the odometer only are visible when first turning the key on. After it starts, they go blank. Also, the battery light in the message center is on constantly. But the battery is getting 14.6 at idle, at the battery. Am I due for a cluster change? Any help is appreciated. Thanks

    Attached Files:

  2. SurrealOne

    SurrealOne Former Member 1000 Posts 100 Posts

    Welcome! :great:
  3. Enkeiavalanche

    Enkeiavalanche Moderator 1000 Posts 100 Posts

    Nice looking ride... Welcome...
  4. donyms

    donyms Active Member 1000 Posts 100 Posts

    Welcome to the club Kevin, it's great to have you aboard. :glasses:
  5. Bighornkid

    Bighornkid Member 100 Posts

    Welcome to The Club, Kevin. Nice looking truck.
  6. 2011laserblue

    2011laserblue New Member 100 Posts

    Welcome, Kevin!
    Nice truck! :great:

Share This Page