GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Another newbie

Discussion in 'Member Introductions' started by CP10KRK, Mar 23, 2013.

  1. CP10KRK

    CP10KRK New Member

    Joined:
    Mar 23, 2013
    Messages:
    3
    Likes Received:
    0
    Hello Everyone! My name is Kevin and I live in SoCal. I finally decided to buy a truck, a 1999 GMC 1500 SLT. It's a nice truck,Green and Silver with Escalade chrome wheels. But it has a problem with the gauges, as in none of them work. The tach and speedo are good, but that's all. The gear indicator and the odometer only are visible when first turning the key on. After it starts, they go blank. Also, the battery light in the message center is on constantly. But the battery is getting 14.6 at idle, at the battery. Am I due for a cluster change? Any help is appreciated. Thanks

    Attached Files:

    #1
  2. SurrealOne

    SurrealOne Former Member

    Joined:
    Aug 14, 2011
    Messages:
    10,778
    Likes Received:
    13
    Welcome! :great:
    #2
  3. Enkeiavalanche

    Enkeiavalanche Moderator

    Joined:
    Apr 5, 2010
    Messages:
    5,365
    Likes Received:
    14
    Nice looking ride... Welcome...
    #3
  4. donyms

    donyms New Member

    Joined:
    Feb 10, 2010
    Messages:
    3,348
    Likes Received:
    5
    Welcome to the club Kevin, it's great to have you aboard. :glasses:
    #4
  5. Bighornkid

    Bighornkid New Member

    Joined:
    Feb 16, 2012
    Messages:
    308
    Likes Received:
    0
    Welcome to The Club, Kevin. Nice looking truck.
    #5
  6. 2011laserblue

    2011laserblue New Member

    Joined:
    Jun 8, 2011
    Messages:
    268
    Likes Received:
    1
    Welcome, Kevin!
    Nice truck! :great:
    #6

Share This Page