1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

anti lock brake probs

Discussion in 'Lifted & Offroad Suspension' started by bigproskine, Nov 27, 2009.

  1. bigproskine

    bigproskine Member

    when ever you hit the bakes to stop get below 5 mph and anti lock brakes kick in.. what is my problem? when you hit the break hard fells like it pulls the tire o5 silverado 4x4 ext v8 4 wheel disc brakes. got any advice for me??
  2. bigredb714

    bigredb714 New Member

    I got a 2003 chevy silverado reg cab 4.8 v8 4x4 and i got the same problem with my brakes. I dont know what the problem is but i really need to find out before I end up in a accident. Let me know if you figure out what the problem is and I will do the same. Thanks
  3. getawaycars

    getawaycars New Member

    It's probably a bad sensor at one of the wheels.

    You'll need to have the abs system computer scanned at a repair shop to figure out which one.
  4. BASSIST

    BASSIST Rockstar 100 Posts

    You have a wheel speed sensor that is dropping out at low speed and needs replaced
  5. hore_racing

    hore_racing New Member

    i got an 03 yukon with the all wheel drive system and it does it too at low speeds as well as when starting off from a stop the traction control will freak out and pull power some times im pretty sure its a wheel speed sensor as wheel since they are used for both abs and traction control im gona look into it some more this weekend and let ya know

    - derrick
  6. Beer Belly

    Beer Belly Rockstar

    I thought I read somewhere that there was a recall for late 90's- early 2000 trucks for" unintended low speed ABS activation"....my dealer sez that my year (2006) was not covered, called GM and asked if they were going to expand the recall, they said "no".....I wrote the NHSTB to report the problem to try and get a recall going....call GM, write the NHSTB and maybe this will be extended to later years.
  7. hore_racing

    hore_racing New Member

    so i just did a hub assem on my LF and the abs seems to be happy again... and no more traction control freakin out so ya i think that fixed it ill put a few more miles on it this week and see if it fixed it for sure
  8. bigproskine

    bigproskine Member

    yes the abs wheel speed sensor i gues the are pron to rust and go bad
    thats the problem
  9. BillNH

    BillNH New Member

    Its a wheel speed sensor. I ended up changing both hubs and sending GM the bill and they paid it. I got the recall after I changed them.

Share This Page