1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

any mechanics here? I have a 1997 chevy blazer with rough idling any ideas?

Discussion in 'Chevy Blazer Forum (GMC Jimmy)' started by Chevyman12helP, May 4, 2012.

  1. Chevyman12helP

    Chevyman12helP New Member

    Help i have a 97 chevy blazer and it is really me off i have changed the injectors after i changed the injectors it started to run rough it didnt do it before the new injectors we hooked up a car md and it read that bank 3 was misfiring and i changed that spark plug and it is still running the same. it runs rough in park and kinda jumps up and it acts like it does nt have all the power it suppose to have any suggestions> ??????? also someone said it may be the o2 sensors and also may be the pcv valve? any ideas please help i cant afford labor costs!!!!!
  2. HDFF

    HDFF New Member

    clean throttle body and tps with proper cleaners and i think you will discover a new running blazer.
  3. MrShorty

    MrShorty Moderator Staff Member 1000 Posts 100 Posts

    Did the misfire code go away? Is it consistently on #3 or does it move around? There's certainly a lot more to a misfire than a bad spark plug. O2 sensor certainly possible, but do you have any concrete indication that the O2 sensor is bad (O2 sensor code or data)? At this point, my advice would be to hook the car md back up, clear the old code, then scan it again for new codes. Diagnose from there.
  4. K15 Blazer Guy

    K15 Blazer Guy New Member 100 Posts

    check your fuel pressure, and check your compression in each cylinder first.
    both tools can be rented for FREE at an autoparts store and take only a few moments.
    if they both come back OK then you know your repair bill with be $XXX rather than $XXXX+
    lol
    but if you have already changed the injectors and plugs.... push-rod may be bent. idk. do those tests first.
  5. moogvo

    moogvo Moderator 1000 Posts 100 Posts

    Did you change the wires?
  6. RayVoy

    RayVoy Active Member 1000 Posts 100 Posts

    Hey guys, this is an old (May 2012) thread, op has not been back.

Share This Page