1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Bad Idle

Discussion in 'Chevy C/K Truck Forum' started by Camo91, Jun 2, 2007.

  1. Camo91

    Camo91 New Member

    I have a 1991 silverado ext cab. It has the 305 in it, I have had this idle problem for a couple of months and it is driving me crazy. It started one day like it runs perfect but if you come to a stop and hold the brake for a min. then the idle with slowly go down till it cuts off. It doesnt do it all the time but majority of it, I have checked for vacum leaks and couldnt find any, cleaned the tbi with cleaner. I finally put it in a shop and payed the guy to keep it for 2 days to tell me it needed a new computer, so I wasted the money and bought that and it didnt do anything. I have also replaced the fuel filter and no help. Sometimes it will even do it just idle in park and idle down till it cuts off, and only does it at normal temp. Just need a few more ideas of what it could be. Thanks
     
  2. bart6180

    bart6180 Member

    did you check the throttle position sensor?? i used to have a car that did the same thing, i changed the sensor and it ran fine after that
     
  3. Camo91

    Camo91 New Member

    Yea I did think about changing that out but the mechanic I took it to said that was fine. He also said my computer was bad too. Any other suggestions anyone?
     
  4. Davandy

    Davandy Moderator 5+ Years ROTM Winner 1000 Posts

    Welcome to the site,
    Did you check the brake booster for vacuum leaks?
    The symptoms you described point in that direction :yes:
     
  5. unplugged

    unplugged Epic Member 5+ Years 1000 Posts

    Tough one

    Troubleshooting a rough idle is a complex process. There are many factors which affect the idle speed, some of which have already been mentioned. You need to get a checklist together and eliminate each item before moving onto the next. No one on the board will be able to point you to the single cause of your trouble. We can all share our experience but your results may vary. Your clues about the trouble being intermittent and that applying the brakes contributes may help, but in the end you have your work cut out for you if you are going to pinpoint the problem.

    Here is a link to a troubleshooting guide for TBI that may help: affordable fuel injection
     
  6. rohr425

    rohr425 New Member

    hard to say with out in in frnt of me but i would check base timing do u have check engine light on?
     
  7. Camo91

    Camo91 New Member

    The shop I took it to checked the timing and said it was where it was supposed to be. No it has no check engine light and is throwing no codes. Was considering changing spark plugs and/or wires.
     
  8. Camo91

    Camo91 New Member

    Ok I still have this problem, what does everybody put there vote in for the next part I will buy. Throttle position sensor or idle air control? Let me know Thanks
     
  9. 84fiero123

    84fiero123 Epic Member 5+ Years 1000 Posts Platinum Contributor

    Did you change the plugs?

    If not change them.

    Also it can be something as simple as a loose plug wire, or defective one. Grab a hold of the plug wires and wiggle them. Now that I have your attention, because you just shocked yourself.

    Does the engine skip or idle ruff? Those are signs of a missing plug or bad wire or loose wire.
     
  10. Camo91

    Camo91 New Member

    Yea I changed the plugs. It idles smooth it just slowly idles down till it cuts off. It doesnt do it all the time but majority of the time
     

Share This Page