GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

Bad Idle

Discussion in 'Chevy C/K Truck Forum' started by Camo91, Jun 2, 2007.

  1. Camo91

    Camo91 New Member

    Joined:
    Jun 2, 2007
    Messages:
    11
    Likes Received:
    0
    I have a 1991 silverado ext cab. It has the 305 in it, I have had this idle problem for a couple of months and it is driving me crazy. It started one day like it runs perfect but if you come to a stop and hold the brake for a min. then the idle with slowly go down till it cuts off. It doesnt do it all the time but majority of it, I have checked for vacum leaks and couldnt find any, cleaned the tbi with cleaner. I finally put it in a shop and payed the guy to keep it for 2 days to tell me it needed a new computer, so I wasted the money and bought that and it didnt do anything. I have also replaced the fuel filter and no help. Sometimes it will even do it just idle in park and idle down till it cuts off, and only does it at normal temp. Just need a few more ideas of what it could be. Thanks
    #1
  2. bart6180

    bart6180 New Member

    Joined:
    May 29, 2007
    Messages:
    38
    Likes Received:
    0
    did you check the throttle position sensor?? i used to have a car that did the same thing, i changed the sensor and it ran fine after that
    #2
  3. Camo91

    Camo91 New Member

    Joined:
    Jun 2, 2007
    Messages:
    11
    Likes Received:
    0
    Yea I did think about changing that out but the mechanic I took it to said that was fine. He also said my computer was bad too. Any other suggestions anyone?
    #3
  4. Davandy

    Davandy Moderator

    Joined:
    Jun 29, 2005
    Messages:
    1,550
    Likes Received:
    6
    Welcome to the site,
    Did you check the brake booster for vacuum leaks?
    The symptoms you described point in that direction :yes:
    #4
  5. unplugged

    unplugged New Member

    Joined:
    Sep 9, 2006
    Messages:
    2,554
    Likes Received:
    12
    Tough one

    Troubleshooting a rough idle is a complex process. There are many factors which affect the idle speed, some of which have already been mentioned. You need to get a checklist together and eliminate each item before moving onto the next. No one on the board will be able to point you to the single cause of your trouble. We can all share our experience but your results may vary. Your clues about the trouble being intermittent and that applying the brakes contributes may help, but in the end you have your work cut out for you if you are going to pinpoint the problem.

    Here is a link to a troubleshooting guide for TBI that may help: affordable fuel injection
    #5
  6. rohr425

    rohr425 New Member

    Joined:
    Jun 8, 2007
    Messages:
    6
    Likes Received:
    0
    hard to say with out in in frnt of me but i would check base timing do u have check engine light on?
    #6
  7. Camo91

    Camo91 New Member

    Joined:
    Jun 2, 2007
    Messages:
    11
    Likes Received:
    0
    The shop I took it to checked the timing and said it was where it was supposed to be. No it has no check engine light and is throwing no codes. Was considering changing spark plugs and/or wires.
    #7
  8. Camo91

    Camo91 New Member

    Joined:
    Jun 2, 2007
    Messages:
    11
    Likes Received:
    0
    Ok I still have this problem, what does everybody put there vote in for the next part I will buy. Throttle position sensor or idle air control? Let me know Thanks
    #8
  9. 84fiero123

    84fiero123 New Member

    Joined:
    Jun 13, 2005
    Messages:
    1,682
    Likes Received:
    9
    Did you change the plugs?

    If not change them.

    Also it can be something as simple as a loose plug wire, or defective one. Grab a hold of the plug wires and wiggle them. Now that I have your attention, because you just shocked yourself.

    Does the engine skip or idle ruff? Those are signs of a missing plug or bad wire or loose wire.
    #9
  10. Camo91

    Camo91 New Member

    Joined:
    Jun 2, 2007
    Messages:
    11
    Likes Received:
    0
    Yea I changed the plugs. It idles smooth it just slowly idles down till it cuts off. It doesnt do it all the time but majority of the time
    #10
  11. tbplus10

    tbplus10 Moderator

    Joined:
    Mar 14, 2007
    Messages:
    5,405
    Likes Received:
    25
    Try cleaning the TPS and IAC with carb cleaner before you replace them. Sometimes they can get a build up of trash on them that affects their operation.
    #11
  12. KrazeyKraker

    KrazeyKraker New Member

    Joined:
    Sep 4, 2006
    Messages:
    4
    Likes Received:
    0
    I would replace your vacum lines, clean your injectors , check fuel pump and filter, spark plug wires, spark plugs, distributer, thats all i can think of right now, tps or throttle posisition sensor, the iacv or idle air control valve as well. hope you find the problem and hope this helps
    #12

Share This Page