Bank 1 to lean, trouble code, help

Discussion in 'GM Powertrain' started by itsabowtime2, Jan 3, 2010.

  1. itsabowtime2

    itsabowtime2 Rockstar

    The check engine light came on this morning.

    Bank 1 is running lean. I'm thinking a vacuum issue, or perhaps an O2 sensor. But which O2 sensor?

    Truck had a rough idle this morning on start up. Once warm it was fine. Lighht came on after a short trip to the store.

    Has anyone had the same issue/code? What solved it for you? I have new plugs and Sea Foam waiting for a warm day to do, provided I can solve the check engine light issue. I have disconnected the battery to see if the code comes back.

    Thanks for any help.
     
    Last edited: Jan 3, 2010
  2. 02greenmachine

    02greenmachine New Member

    I just had the same problem recently but it was bank 1 and bank 2 were lean. The truck would start up and rev to about 2k rpms then it would drop down to a rough 4-500 rpm. It only did it when it was cold outside, I chased down a few little things but it ended up being the intake gaskets. The gaskets were $40 and about 1.5 hours of my time, didnt even have to drain the coolant. My truck has 136k on it
     
  3. BASSIST

    BASSIST Rockstar 100 Posts

    What trouble code do you have?
     
  4. itsabowtime2

    itsabowtime2 Rockstar

    Had a ran at a parts store. The counter sales person said it was "Bank 1 is running lean"
     
  5. BLK-Z71

    BLK-Z71 Epic Member 5+ Years 500 Posts

    Me too p0171,po174. bank 1&2 too lean!!!
     
  6. azdrtdog

    azdrtdog Epic Member 5+ Years 100 Posts

    use some carb cleaner to find the leak while its running
     
  7. itsabowtime2

    itsabowtime2 Rockstar


    What do you think is causing it? Vacuum leak is my first guess. Intake gaskets, as a member suggested may be my first stop.
     
  8. BLK-Z71

    BLK-Z71 Epic Member 5+ Years 500 Posts

    my truck is goin in on wed. i'll let you know what happens!!
     
  9. itsabowtime2

    itsabowtime2 Rockstar

    Thanks.

    I connected the battery this morning and the light stayed on, until the engine got up to operating temp, then the check engine light went off. I love chasing Gremlins.
     
  10. J_chevyman

    J_chevyman Rockstar

    RE`

    Anyone find out what the code was? I have the same thing lol
     

Share This Page

Newest Gallery Photos