Blinkers and B/U Lights don't work

Discussion in 'Chevy C/K Truck Forum' started by dadeans, Oct 21, 2010.

  1. dadeans

    dadeans New Member

    The turn signals and the back up lights on my 1995 chevy C1500 stopped working. They are both on the same circuit. The fuse is good and there is 12v at the line side of the fuse and at the plug for the B/U lights to the transmission. Checked the flasher just for grins and it is ok too. Hazard flashers work fine. Any ideas? Maybe the multi-switch?
     
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Check power at the light bulb, im thinking your circut boards for the tail lights might be fried, and or the ground could be as well..
     
  3. okysmokey911

    okysmokey911 Rockstar 100 Posts

    I'm also going with tail light circuit boards being fried.... but what caused them to be fried....... not too sure about that. Maybe a short somewhere.
     
  4. dadeans

    dadeans New Member

    There is no power at the tail lights or connectors.

    Someone else suggested it might be the multi-switch. Does the power for the back up lights go through the multi-switch? The truck is 5 speed and there is 12v at the plug on the transmission for the B/U lights.
     
  5. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Then i would climb under the truck and check for power at the connector by the spare tire since the rear tailight harness is FAMOUS for frying on these trucks, and the trailer wiring plug and connections can get dirty causing the same issue. Ive had 2 harness's go out of the 6 88-98 trucks that i have owned.
     

Share This Page

Newest Gallery Photos