1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Boggy engine on 1999 5.3

Discussion in 'Performance & Fuel' started by vncj96, Jul 17, 2012.

  1. vncj96

    vncj96 Epic Member 5+ Years 1000 Posts

    I have replaced the front O2 sensors, fuel pump, fuel pressure regulater and the fuel filter. After the truck has sat and completely cooled, upon start up it really boggy when trying to get going from a dead stop. It also just doesnt seem to have the high end that it should and once did, when attempting to pass a car on the highway. It for sure doesnt have the passing power and take off that my 99 suburban has. i have no toher codes showing and am windering what else it could be. Start of the intake gasket going???? I still get 17-17.5 mpg on the highway even with the bigger mudd tires on it, so this is really confusing me........
  2. dpeter

    dpeter Rockstar 3 Years 100 Posts

    Does the installation of the bigger tires happen to be about the same time your performance issue showed up?
  3. Patrick S

    Patrick S New Member

    Try replacing the mass airflow sensor, i had the same problem with my 97.

Share This Page