1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

both low beams out at the same time?

Discussion in 'GM Electrical Tech' started by quicksilver8817, Feb 7, 2011.

  1. quicksilver8817

    quicksilver8817 New Member

    i cant find a fuse and the bulbs seem to be okay . the highs still work. is there a relay?
  2. TritonBoulder47

    TritonBoulder47 New Member

    What year truck...? There should be a relay and a fuse for each set of lights. It's in the under hood fuse panel...
  3. murdog94

    murdog94 New Member 1000 Posts

    Yep more on the year, since i have had the multifunction switch act funny, and when you go to high beams it will stick, and when you try to switch back to lows they wont come on. Also the head light switch. But as mentioned start with relays etc.
  4. quicksilver8817

    quicksilver8817 New Member

    well its a 1990 k 1500 . uhm i cant seem to find a fuse . last night the low beams came back on . i have a spare headlight switch and it had no effect . so idk what it is unless there is a relay but i dont know where its located .
  5. murdog94

    murdog94 New Member 1000 Posts

    There isnt a relay.. it sounds like your Multifunction is shot.
  6. quicksilver8817

    quicksilver8817 New Member

    idk the weird thing is my plow lights are wired with my low beams. But when my low beams went out my plow lights still worked .
  7. murdog94

    murdog94 New Member 1000 Posts

    See you failed to mention that you have a plow. I cant really help you much there since ive never had a problem with lighting on a plow. But it does sound like you have a crossed wire etc..
    And alot of the plows that i have delt with and or driven have had it set up where the only lights that worked were the ones on the plow.
  8. quicksilver8817

    quicksilver8817 New Member

    well an update the switch that switches my headlights to the plow lights was going bad..

Share This Page