1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Broken speedo on a 1999 2500 Suburban...help?

Discussion in 'General Chevy & GM Tech Questions' started by Stevodod, May 20, 2011.

  1. Stevodod

    Stevodod New Member

    The speedometer and odometer are not working on my 1999 Suburban 2500 4x4 gov't issue. I replaced the sensor thingy at the transmission, replaced the speedo itself, and I'm at a loss. These don't have a cable, so I don't know what to do - thoughts?

    Thanks,

    Stevo
  2. KidHauler

    KidHauler Epic Member 5+ Years 500 Posts

    Maybe the fuse? When I first wired in accessories, I used that fuse and it blew out while my wife was driving, which shut the truck down.

    Is yours still running, just no speedo?
  3. Stevodod

    Stevodod New Member

    It runs like a champ, I should have mentioned- it comes 'on' about every 100 miles, just for a few miles and works fine, then dies off...weird......

    stevo
  4. KidHauler

    KidHauler Epic Member 5+ Years 500 Posts

    Well, I always say "it's a ground issue", but I haven't had the dash apart on mine yet. Something's loosing signal somewhere - I'll see what I can come up with...

    Good luck,
  5. Stevodod

    Stevodod New Member

    Yeah, I wish I could track it.....thanks!

    Steve
  6. Stevodod

    Stevodod New Member

    Speedo still not working!

    Alright, replaced the dash 3 times, took it to chevy and they say possibly the ECM. But they are not sure and want to charge $700. What to do here? I can get a used ECM this weekend, but will it fix a speedometer?

    Thanks,

    Stevo

Share This Page