1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Bucking 1999 Suburban between 1k-2k rpm?

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by janikphoto, Dec 6, 2012.

Random Gallery Photos

  1. janikphoto

    janikphoto New Member 100 Posts

    So, the suburban started doing this bucking thing between 1k and 2k rpm, but drives smooth above that. It also seems to happen only after the engine is up to full temp, after about ten minutes of driving. It will go away if the engine has a chance to cool down before driving again. It also doesn't buck when the rpm is going back down through the 2k to 1k range with my foot off the gas. But then, going back up through that range, even with the slightest pressure on the gas, and it bucks and shakes until I get above 2k... then it drives fine!

    I recently had the timing chain replaced and I have almost 200k miles. I was wondering if it's something like a crank sensor getting heat-soaked, or if it's timing/distributor related, or if it's torque converter lock-up related?!? I don't think it's fuel delivery related at this point. Anyone else experience this?

    - - - Updated - - -

    hmmm... Not a good sign, if I have 73 views and zero replies. I'm guessing that means nobody has a clue as to the source of this problem.
  2. janikphoto

    janikphoto New Member 100 Posts

    FYI, it turned out to be a sensor that was going bad. Looks like it was a crank position sensor? Or, maybe they sad a cam position sensor. Either way, it is good now!

Share This Page