1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Burb fails smog check

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by unplugged, Oct 9, 2007.

  1. unplugged

    unplugged New Member 1000 Posts

    The burb failed its smog test yesterday. CO levels were a tad high. Took it to a test only station and besides the CO, the gas cap did not pass either. I thought I'd start with cleaning the K&N and a fresh set of plugs. Any suggestions?
  2. 84fiero123

    84fiero123 New Member Platinum Contributor 1000 Posts

    Did you drive it at least a half hour before the smog test was done?

    If you did not it may have still been in the start up mode. High fuel or whatever it’s called. I know when we lived in Taxachusetts if the vehicle wasn’t warmed up it would never pass.
  3. GaryL

    GaryL New Member ROTM Winner Platinum Contributor 1000 Posts

    Try running some fuel injector cleaner/engine treatment through it. If you had failed on NOx then I would have suggested EGR or Cat, but CO just sounds like it is dirty somewhere. And as Fiero said, warm it up real nice. Good luck.
  4. unplugged

    unplugged New Member 1000 Posts

    Cool, I'll give it a try. Stay tuned for test#2 results.
  5. unplugged

    unplugged New Member 1000 Posts

    New plugs and air filter. Dumped a can of seafoam in the tank and going for a retest today. Plugs 1 & 3 showed signs of wear. Hope for the best.
  6. Cableguy

    Cableguy Active Member ROTM Winner 1000 Posts

    Good luck! Don't forget about 10 mile tour at freeway speeds then go right in to be tested. Don't shut it off when you get there.
  7. unplugged

    unplugged New Member 1000 Posts

    Failed test #2. The 1st tech was a tard! The second tech spotted it right away. Bad cat! Quoted $140 for a cat or $340 for cat and a cat back system with a Magnaflow and 3" pipe with the mandatory chrome tip. Went for the whole package and the 3rd test passed! Whoopee:party:
    Sounds mellow enough too. Can't wait for the Cajon Pass climbing test to see if there are any extra benefits in the HP department.
  8. Cableguy

    Cableguy Active Member ROTM Winner 1000 Posts

    Plugged cat? Well I'll be damned. I'm surprised you didn't feel that earlier...? Anyway good for you, an unexpected upgrade. :great:
  9. unplugged

    unplugged New Member 1000 Posts

    Cat wasn't plugged, just worn out. 240k and it was done. btw went to a test only station, so they weren't trying to sell me anything. Howard's Muffler quoted me a fair price and got the job done the same day!:great:
  10. GaryL

    GaryL New Member ROTM Winner Platinum Contributor 1000 Posts

    See, I told you so!! :lol: I have the Magnaflow catback on my 99 and love it. Nice mellow tone and a few more ponies pushing it.

Share This Page