GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

can anyone help me???

Discussion in 'General Chevy & GM Tech Questions' started by Paul Whyte, Jan 8, 2012.

  1. Paul Whyte

    Paul Whyte New Member

    Joined:
    Jan 8, 2012
    Messages:
    2
    Likes Received:
    0
    ok so I have a 1994 chevy k2500 with a 454 in it. I am having trouble driving it. it starts up fine like nothing is wrong with it but when u try to accelerator it tries to stall. I have replaced the fuel pump about 4 months ago, the filter also, I have replaced the timing chain, distributor cap, an rotor, new plugs an wires, ignition module, ignition coil, throttle posotion sensor, set timing, took off the catylatic converter, Idk whats wrong need help....
    #1
  2. tbplus10

    tbplus10 Moderator

    Joined:
    Mar 14, 2007
    Messages:
    5,405
    Likes Received:
    25
    Have you checked the injector pressures?
    Also might want to look at timing advancement, this yr model is electronic computer controlled so you'll need to look up the troubleshooting tecniques for it.
    "took off the catalytic convertor" that'll give you some codes right there that may confuse the issue when troubleshooting, you'll have to sort that out first. Have you checked for any codes yet?
    #2
  3. Paul Whyte

    Paul Whyte New Member

    Joined:
    Jan 8, 2012
    Messages:
    2
    Likes Received:
    0
    yes i have but no codes pop up. its starting to make a loud sucking sound coming from the throttle body it happens off an on.
    #3

Share This Page