Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Changed the fluid, put in Lucas tranny fix; P1870 code came back...

Discussion in 'GM Powertrain' started by idowa, Aug 29, 2010.

  1. idowa

    idowa New Member

    Just bought the Suburban and it had the P1870 code come on during the 80 mile drive home so I dropped the pan and the old fluid was incredibly bad; almost brown.

    Put in the Mobil 1 synthetic tranny fluid, new filter, and bottle of Lucas tranny fix. Light went off and it shifted like a new tranny. Not alot of clutch material in the pan nor any debris, so thought the fluid change would fix it, but the light came on after an hour of driving, and it started getting the hard 1-2 shift again.

    Tranny isn't slipping, so I don't know what is going on...:grrrrrr:

    I guess my next step is to install a shift kit??
     
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Did you change all 16 quarts in the tranny or just the 4or 5 in the pan???
     
  3. idowa

    idowa New Member

    Just what was in the pan...:whistle:

    Guess I should disconnect the tranny cooler line at the radiator and pump all of it out...

    But that Mobil 1 stuff is spendy!:grrrrrr::grrrrrr:
     
  4. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Oh i got ya.. i put in the cheap stuff to get good fluid in and when i change the filter after ive done the change i usually put in the good stuff, and i would be sure to do the lucas oil again.
     

Share This Page