check engine light after installing cat back system

Discussion in 'General Chevy & GM Tech Questions' started by kennyb79, Mar 20, 2011.

  1. kennyb79

    kennyb79 Rockstar 100 Posts

    sooooo I installed my new cat-back system on my 2003 suburban...took it for a test drive and about 5 miles down the road the check engine light came on...is this common until the SS burns itself off a little...it new pipes sure stink? I haven't taken it to run the codes yet, thats tomorrow after work I guess.
     
  2. pacecar68

    pacecar68 New Member

    you need the code(s)....

    it is not uncommon for high flow cats to result in CELs. did you fit your truck with them? sometimes not enough exhaust hangs around the rear O2 sensors. there are work-arounds. some people fit the rear O2s with spacers to address the problem.
     
  3. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    If you only replaced the exhaust from the cat-back that shouldn't throw a code. What cat-back kit did you install?? Did you disconnect the O2's to install kit or maybe pull on the wires when installing cat-back?
     
  4. kennyb79

    kennyb79 Rockstar 100 Posts

    magnaflow cat back...I tried to stay away from the sensors but I may have caught one by acccident. are there 4 sensors on the suburban? I can see 2 of them, before and after the cat.
     
  5. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    I have Magnaflow cat-backs on all my trucks and have never had code thrown because of them. Yes there are four O2's on your truck. Check and see if you disturbed any of them when you installed your cat-back. Also if you have a AutoZone near you have them scan for codes and turn off the SES and see if it comes back on.
     
  6. kennyb79

    kennyb79 Rockstar 100 Posts

    came back as a po135 code, which is bank 1 sensor 1 which is the O2 sensor on the drivers side, about as far away from the cat as you can get. I guess it was all coincidental...and yes, after crawling all over underneath there are 4 of them under there. I've clered the code and the CEL we'll see if it comes back.
     
  7. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    Sounds coincidental, wait and see if it comes on again. Good luck!
     

Share This Page

Newest Gallery Photos