Chevy 7.4 Starts and then Quits

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by lute, Oct 21, 2011.

  1. lute

    lute New Member

    7.4 had leaking manifold gaskets, so I replaced upper and lower. All was well.

    Then 500 miles later developed a persistent fast idle and vacuum leak.
    Turned out to be a loose lower intake manifold bolt. (Oops)
    When diagnosing the fast idle problem, I went to clean IAC and it came apart, so I replaced it with one from Autozone.

    Now the truck idles great and runs well.
    Problem is when first started it runs for a second and quits.
    Then when restarted it keeps running.
    But when first started it always dies.

    Any suggestions?
     
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Take a look at the fuel pressure. without knowing more info. (year, make, model) it is hard to tell you much more.
     
  3. lute

    lute New Member

    This is a '96 GMC C3500. Fuel pump and filter are fairly new. It will pull a 32' trailer up the side of a mountain fine,
    but it takes two tries to start it.
     
  4. steverocks6

    steverocks6 Member

    try getting new IAC, sometimes they could come faulty from parts store, seeing how everything worked before you replaced that i would just return the one you purchased and get new one and try it out
     
  5. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Alright well i would double check the pressue since the GM pumps are known for crummy well everything. 55-60PSI you must have 58PSI to start. also take a look at the FPR while in there if it is leaking down there is a chance that when you start the first time it dumps the pressure, then holds it on the second try.
     

Share This Page

Newest Gallery Photos