1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Climate control screen blank

Discussion in 'Audio, Video & Gadget Tech' started by flamingo1one, Nov 6, 2008.

Newest Gallery Photos

  1. flamingo1one

    flamingo1one New Member

    The climate control screen went blank on my 04 TB LS. Nothing works (temp controls, rear defog, AC button etc), however, all other parts of the dash work fine.
     
  2. MWright936

    MWright936 Epic Member 5+ Years 1000 Posts

    Check fuses maybe? Sounds to me like it would either be a blown fuse or a short somewhere, but I'm no expert.
     
  3. ChevyFan

    ChevyFan November Beard Grower - Cancer Fighter Staff Member 5+ Years 5000 Posts

    I've not heard of this before, so it's either a fuse, a disconnected wire/short, or perhaps the unit went bad? I know that people have tried to go from manual system to install the digital and it's not a direct swap, so I hope yours came from the factory. In any case, it seems pretty rare for this.

    ... moved to electrical.
     
  4. tlperry68

    tlperry68 Epic Member 5+ Years 1000 Posts

    Try the fuses first, if not unplug the car battery for a few minutes the plug it back in. My wife has a 2009 journey, this has happened to her espically when she uses the remote start. We are waiting for the dealer to fix this.
     
  5. 04sierracrewcab

    04sierracrewcab Epic Member 5+ Years 1000 Posts

    agreed check the fuses then get back to us!
     

Share This Page