Clink/Clunk Sound

Discussion in 'Lifted & Offroad Suspension' started by Tdaz250, Aug 11, 2009.

  1. Tdaz250

    Tdaz250 Rockstar 100 Posts

    Hey everyone. My truck makes this weird clunk sound whenever i go over speed bumps. It sounds like its coming from the back and it only makes the sound when i go over things with the back tires. Its just starting to worry me every time i hear it, sounds like something is loose and i dont want to find out the hard way one day what it is. Any help as to what it could be is greatly appreciated :money:
     
  2. vncj96

    vncj96 Epic Member 5+ Years 1000 Posts

    could be so many things, your spare tire could be loose, exhaust bracket/hanger broken, yor license plate could be missing a few screws and clankin around. could be a dosy bracket has broken that supprts the quarterpanels. All I can say is just go back there and start hitting thins I am thinking something is just loose
     
  3. MWright936

    MWright936 Epic Member 5+ Years 1000 Posts

    Do you have a trailer hitch? I keep mine on all the time and when I go over bumps, sometimes I can hear the hitch mount move in the receiver, making a clunking noise.
     
  4. Tdaz250

    Tdaz250 Rockstar 100 Posts

    No i dont have a hitch in right now, i have the lock that locks the hitch in on there but im pretty sure thats not it. Could it be something with the leaf springs/shocks?
     
  5. 5speedsilverado

    5speedsilverado Epic Member 5+ Years 1000 Posts

    might sound dumb, but make sure their is nothing in the bed that could bounce, i forgot about some tie down straps that were their, every time i hit a speed bump the bounced off the bead, and came back down.
     
  6. Tdaz250

    Tdaz250 Rockstar 100 Posts

    I dont really leave anything in the bed so i doubt thats the problem...thanks for the input though.
     
  7. Tdaz250

    Tdaz250 Rockstar 100 Posts

    Bump

    Bump Bump Bump
     
  8. willbradfan

    willbradfan Rockstar 100 Posts

    I had a clink/clunk sound as well on my truck and finally took it to the dealership and found out that it was a C-clamp on the rear leaf springs that was loose, i didn't replace as the dealer said its nothing to worry about.
     

Share This Page

Newest Gallery Photos