1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

cluster backlighting out... still

Discussion in 'Audio, Video & Gadget Tech' started by oOcornflakeOo, Jan 5, 2009.

  1. oOcornflakeOo

    oOcornflakeOo Rockstar

    So I have my brake lights working again but I'm still without gauge lighting.. I have new LEDs waiting to be tested for the gauge backlighting but I need lighting for the cluster:grrrrrr: any ideas? all the gauges work fine except without night lights.. any help?:neutral:
     
  2. Springthing

    Springthing Epic Member 5+ Years 1000 Posts

    CornFlake-

    I haven't been following the posts about the non-working items but in this situation here I would have to take a methodical approach to it. Do you have a manual / have access to a wiring diagram? What I would do it grab the wiring diagram, get the cluster out and take to the wiring plugs with a meter.

    Try to see if you can peg just where the problem is. If you test the plugs you could determine if you are actually getting power to the gauge when you are supposed to. At the very least it would give you a starting point as to whether the problem is in the gauge of if there's really just no power coming to it when you turn on the lights.

    Just my $.02

    Good luck with it all. I'm sure you'll get lots of helpful tips soon!
     
  3. chevygurl

    chevygurl Rockstar

    I know this may sound like an obvious question, but did you check all your fuses and relays? Sometimes the aftermarket lights will blow a fuse here or there...

    I would definitley start with Springthing's suggestion with the meter, or even just a test light. If you've got an LS or LT, when you take the cluster bezel off, there should be one big harness at the very top of the cluster, you can check that too.

    Good luck!
     
  4. oOcornflakeOo

    oOcornflakeOo Rockstar

    ok so I got an OBD-II tester and it reads, P0650 indicator lamp (MIL) control circuit malfunction.. I don't have time at the moment so I'll get back with you all about it.

    your suggestions are deeply appreciated,
    Dave
     
  5. JMoney02

    JMoney02 Epic Member 5+ Years 500 Posts

    Indicator Lamp Relay has quit working.......How is the dimmer switch also?


    Jeff
     
  6. oOcornflakeOo

    oOcornflakeOo Rockstar

    the dimmer wheel controls nothing except to turn on the dome lights when wheeled up all the way...
     
  7. TahoeFever

    TahoeFever Epic Member 5+ Years 500 Posts

    any luck on this issue ?
     

Share This Page