Code P0303 What Could It Be??

Discussion in 'General Chevy & GM Tech Questions' started by marcos, Jan 21, 2014.

  1. marcos

    marcos New Member


    • Hi, I'm new to the forum and don't know a whole lot but am trying to figure my problem out. I have a 96 Chevy Express 1500 with a 5.7 350 in it and it is running really sluggish and is having misfire code(p303-misfire)service engine[​IMG] soon light is on. It started doing it when I was heading up a hill, it just started bogging and has been doing it ever since especially when I give it a lot of gas. I thought was a lifters problem plus rods (i replaced all that) and was no luck problem is still there ,haven't replaced the plugs and wires as well as cap/rotor . I have been researching the common fuel intake problems with the motor and am starting to think I need to clean the injectors (spider replacing ). It has 160000 miles on it . Does anyone have any good suggestions to try anything. Any ideas to what it could be. It seems to idle right and drives ok at the beginning , but when i want the overdrive the hole maracas comes out to play.

      Thank you​






     
  2. 99'HEARTBEAT

    99'HEARTBEAT Epic Member Staff Member 5+ Years ROTM Winner 1000 Posts Platinum Contributor

    ****THREAD MOVED****
    To The
    GENERAL CHEVY/GM TECH QUESTION SECTION

     
  3. dpeter

    dpeter Rockstar 4 Years 500 Posts

    I would suspect a fuel delivery problem also. Under no or low load runs fine but give it gas and it falls on it's face? Check the fuel pressure and change the filter for a start. I don't have the pressure specs for the 96.
     
  4. RayVoy

    RayVoy Well-Known Member 2 Years 1000 Posts

    P0303 is a mis-fire on cylinder #3.

    It could be many things, I would check the common ones and the simpler ones first. The most common problem is "no spark". This could be a bad plug, a bad wire, a bad dist cap.

    Number 3 is the cylinder that is 2nd from the front on the driver's side.

    Edit:
    as I re-read your post, I think you may have changed the plugs/wires/cap, although, the posts does not read that way.
     
  5. marcos

    marcos New Member

    it sounds like was a lifter stuck, but was not i still have the knock, now im looking to change all the , (plugs/cables/rotor-n-cap and ignition ) will be crossing my fingers.
    Thanks for your imput



    - - - Updated - - -

    i should have wrote code,,,,P0300,,,,MULTIPLES MISFIRES,,Sfor the mistype
     

Share This Page

Newest Gallery Photos