Compass/temp mirror acting wierd.

Discussion in 'Chevy Avalanche Forum (Escalade EXT)' started by TrailLeadr, Jan 25, 2007.

  1. TrailLeadr

    TrailLeadr Epic Member 5+ Years 1000 Posts

    A few days ago the we decided to do a family dinner, at McD's:tongue:
    It was raining, and while we sat waiting for our order in the drive through I noticed that each time the wipers would come on (they were on intermittent) the compass, and thermometer in the rear view mirror would go nutty. It would actually look like it was in test mode. All available characters would light. So it would look like boxes with asterisks (*) inside them. Then it would go back to normal while the wipers were at rest. I'm not too concerned about it just yet, if it happens again or more frequently I'll have it checked.

    But I thought it was weird. Anyone else experience this?
     
  2. GaryL

    GaryL Epic Member 5+ Years ROTM Winner 1000 Posts Platinum Contributor

    Check your wiring connections that run along the windshield to the mirror, they could be loose and the wipers vibrating the window could mess with it.
     
  3. ChevyFan

    ChevyFan The Sheriff Staff Member 5+ Years 5000 Posts

    Did this straighten itself out?
     
  4. Cableguy

    Cableguy Epic Member 5+ Years ROTM Winner 1000 Posts

    Have you turned wipers on since with out it raining? Seems weird.
     
  5. unplugged

    unplugged Epic Member 5+ Years 1000 Posts

    I've seen that on my Silverado, but not with the wipers. (Not much rain in the Mojave) More often than not it occurs first thing on start up. Haven't seen it lately though, but I don't always stare at the mirror when I'm cranking her up.
     
  6. TrailLeadr

    TrailLeadr Epic Member 5+ Years 1000 Posts

    We use Rain-X in the washer reservoir, so the wipers don't always need to be used.

    I forgot to post on this again. The problem never actually happened again, but the root cause showed up about last month when the wife got stuck at work (truck wouldn't start). Her step father went to bail her out. Not sure how it happened, but the positive terminal of the battery was broken nearly off. Almost like someone over torqued the side terminal bolt. when the Avalanche finely made it home, I went to do a once over, and the positive line, and the battery contact came off in my hand.

    I popped a new battery in, and since then there have been no electrical issues.
     
  7. Cableguy

    Cableguy Epic Member 5+ Years ROTM Winner 1000 Posts

    The Avalanche I take it is just for the wife? You need to be more proactive if its the wifes or you won't be gettin' any...:no:
     
  8. TrailLeadr

    TrailLeadr Epic Member 5+ Years 1000 Posts

    True...true...

    What I need to do, is find a spare moment to drop that 454 back into the burb....lol
     
  9. ChevyFan

    ChevyFan The Sheriff Staff Member 5+ Years 5000 Posts

    Any repeat of this issue?
     

Share This Page

Newest Gallery Photos