Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Cooling fan motor relay burning out! (88 Chevy)

Discussion in 'GM Electrical Tech' started by Merkatroyd, May 10, 2013.

  1. Merkatroyd

    Merkatroyd New Member

    I own a 1988 Chevy Suburban, 2wd r10.
    every time I turn the key, after about 15 seconds it burns out the cooling fan motor relay. This part right here:
    http://shop.advanceautoparts.com/bu...fan-motor-relay-by-bwd-part-r4005-relays.html
    After this relay burns out, there are no lights in the dashboard. no ignition, no click, no power. Also, it drains the battery. if I try to jumpstart it afterwards, I get an explosion of sparks when I hook up the alligator clamps to the terminal. Not fun.
    Here is a list of what I've tried so far:
    unplugged the blower motor
    ripped open the harness and dashboard, sifted through piles of multi-colored spaghetti, found nothing. (so far. more suggestions in this department are welcome)
    checked every fuse, none are blown. which makes no sense. why does it burn out the relay instead of a fuse or in-line fuse?
    I haven't recieved much help in the way of wiring diagrams, all of the ones I've found are really simple or partial and don't go very far in depth.
    Any help at all, or gut feelings, or comments are greatly appreciated! this thing's been out of commission for a month and a half. The damn thing doesn't even have an electric cooling fan. (or did it? maybe someone before me modded it.. I think it has a thermal clutch on the fan)
     
  2. zippstripp

    zippstripp Member 1 Year

    Couple questions. When the battery is hooked up key off,does the battery drain by itself? Did this problem just show up or start after another type of repair?
     
  3. Merkatroyd

    Merkatroyd New Member

    Yeah, it drains when the key is off and the battery is connected too. As to whether this problem showed up after another type of repair, The previous owners did a lot of fiddling and improvising to get the a/c to work. It only caused my battery voltmeter in the dashboard to act up, and I THINK it powers that relay.
    I also did some unrelated engine maintenance before this problem. it only involved disconnecting and reconnecting the wiring harness from the motor.
     
  4. zippstripp

    zippstripp Member 1 Year

    Ok,been rolling your symptoms around in my melon. It really sounds like you have a small direct short,maybe some where under the hood. Check the heavy red wires that run from the battery,starter and along the fire wall. Just to see if something rubbed together or got spliced into that shouldn't have(I have seen that). Other than that I'd have to have it in my grasp to look at it. Oh, and check the 12 volt wire to the alternator for the same thing. Hope I've givin you some direction.
     

Share This Page