dead battery !

Discussion in 'Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)' started by loic, Aug 27, 2009.

  1. loic

    loic New Member

    went to start the truck this morning and nothing... be battery gage show 10 V, dash and all the light come on when i turn the key. the battery is just a couple months old.i have read somewhere that a lots of peoples had similar problem and somebody traced it back to the factory radio. I have an aftermarket one.all ideas are welcome !
  2. bill190

    bill190 New Member

    Charge the battery overnight with a battery charger. You can buy these at auto parts stores.

    Then next day, disconnect the charger and check the battery voltage with a multimeter.

    The battery should read 12 something volts with just the ignition on (not started).

    Then start it and it should then read 13/14 volts at the battery. This is the alternator kicking in and charging the battery.
  3. zubbiez

    zubbiez New Member

    If the batteries only a couple of months old take it back to where you bought it. they can test it to see if its just a bad battery and replace it. or if its good they can charge it for you that way youre not having to buy a charger. I would suggest also unplugging you stereo over night after it has been charged it it starts the next day youre stereo is probably to blame.
  4. loic

    loic New Member

    i have a battery charger, but the battery being "new" i'll go replace it. i bought the truck 9 days ago and it always start right up. i'm wondering what will draw the battery like this. if it was the factory radio installed i would be thinking that it may be the problem as it has been documented somewhere, but its an aftermarket...
  5. zubbiez

    zubbiez New Member

    I had an aftermarket stereo in my BMW that would suck the battery down I dont know why but once I switched it out I never had problems again.but diffenitly get the battery replaced regardless of the problem if its been drained to many times itll never hold a good charge
  6. loic

    loic New Member

    well.... I changed the battery but it did the same thing, turned the key......nothing, then keeping the key turned for 2 maybe 3 seconds then it start...... would it be the starter getting stuck ? when I turn the key I don't hear a click from the strater, just nothing and then it give like a slow motion and the engine start.
  7. ChevyFan

    ChevyFan Administrator Staff Member

    What's the Year/Make/Model of the truck?
  8. loic

    loic New Member


    99 tahoe lt

Share This Page