1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

defrost only no foot heat

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by challutz, Feb 12, 2007.

  1. challutz

    challutz New Member

    my 04 LT seems to be stuck on defrost even when i select the foot or face option any suggestions????
  2. challutz

    challutz New Member

    i have checked all the fuses already they are ok , Im new to this electronic hvac so I really dont know where to go from here. thanx cw
  3. challutz

    challutz New Member

    well after reading some posts on here i started exploring around under the driver side and just under the blower is a connector that is going to a module that must work the vent system after pushing on the connector to make sure it was tight and giving a little tap on the module I tried the vents and to my surprise everything works I have all the functions back. I know this may only be a temporary fix especially if the module is going bad but at least i know where to look next time.
  4. ChevyFan

    ChevyFan Administrator Staff Member 5+ Years 5000 Posts

    Hey, another satisfied customer! :) Didn't have to do anything, just let the search function work for us!
  5. GaryL

    GaryL Epic Member 5+ Years ROTM Winner 1000 Posts Platinum Contributor

    You got lucky. The driver's side is pretty easy to get to, but the passenger side requires removing the dash.
  6. challutz

    challutz New Member

    I didnt know there was one on that side too !!! I guess that must control the back huh .

Share This Page