Do I have a bad engine mount on my C1500

Discussion in 'Chevy C/K Truck Forum' started by Crispyt, Jan 14, 2012.

  1. Crispyt

    Crispyt Rockstar 100 Posts

    I have a 1995 Chevy C1500 with a 4.3L engine and a manual 5spd. transmission. Recently I noticed one day that when I was in either 1st or 2nd gear and I really got on the gas or did a fast start my shift lever would kinda rock a bit to the right with the RPMs. Sometimes I can hear a small like knocking sound when I do a fast or hard start in 1st gear when I left off the gas to make a shift. I checked the rear transmission mount and its good and tight. I didn't really check the engine mounts because they are hidden behind the exhaust manifolds. From what I can see the engine is sitting correctly and not sagging to one side. When I hear the knocking sound it seems to be coming from the driver side so it seems like mabye the driver side engine mount is bad.Any ideas? Also if it is bad how hard would it be to replace.Thanks for your help all!
     
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    I kinda doubt it is the engine mount, since the motor would rock alot harder and some torque to the right is normal. If it is bad, they arent that bad you will want an engine lift.
    I would actually look at the U-joints but i dont know exactly what kind of knocking you are talking about since i cant hear it sadly.
     
  3. dipstick

    dipstick Member 2 Years 100 Posts

    Seems if you had a bad mount would be on passenger side.. due to torque of engine.
    Only way to see it have someone to set parking brake ..hold main brake put in gear .
    Crank truck ..put in gear ..give it some gas see if engine lifts up off of mount.
    While standing beside truck.. not in front might get run over if brakes messed up .
    Safety safety first.........................................................................................................................................
     
  4. cooter71

    cooter71 Member

    well im not sure about the shifter. but seriously check the tensioner pulley. my buddy's 305 was making noises like that when the motor bogged down and thats all it was
     

Share This Page

Newest Gallery Photos