Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Doesn't like being warm.....

Discussion in 'Chevy C/K Truck Forum' started by GMANs95, Apr 11, 2014.

  1. GMANs95

    GMANs95 Member

    Hey guys..been a while. truk is running good except for this "new" quirk. After a 20 min/mile drive,(on an already warm day) I turn truk off and when i go to restart it say 5-10 min later she no start?

    I know the IAC is new (when it was rebuilt)

    95 5.7 TBI with less than 3000 miles on reman engine.
  2. silverado002

    silverado002 Member 100 Posts

    Assuming the engine turns over, then I would check for spark. Could be a heat sensitive ign module.
  3. RayVoy

    RayVoy Well-Known Member 2 Years 1000 Posts

    Or perhaps a heat sensitive fuel problem.

    Now, if there is no crank, then you probably have a starter problem.
  4. GMANs95

    GMANs95 Member

    Yea it turns fine. just when i drive about 20 to 25 miles on a "warm" day it gives me fits starting.

    - - - Updated - - -

    Cranks fine. starter is good. IF I let it sit for 20 min i can get it to start...may take 5 or 6 tries but it does.
  5. GMANs95

    GMANs95 Member

    Still having the "warm starting issue". It has now developed into acting like its missing in the morning as i am pulling out of the driveway. (Ignition module?). It goes away as i get farther down the road. On my way to work when I am stopped at an intersection..it will randomly die. Idle seems a bit low to at times but that is ECM controlled.

    I am getting ready to rebuild the TBI this weekend cuz it was the only item that wasn't rebuilt when i put the engine in...not sure why i didn't!? So I am gonna buy the gasket kit and either the ignition module or the TPS and cap and rotor. ECM may come later dunno yet.

    Ideas...advice...always welcome.

Share This Page