Dual A/C Gone Crazy!

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by jabber101, Apr 14, 2010.

Newest Photos

  1. jabber101

    jabber101 New Member

    HELP! I have a 03 burban with Dual Digital A/C controls plus the over head controls for the rear A/C. I noticed about 2 months ago the rear would blow a little warm air compared to the setting I had it at and the passengers side would do the same. I took it to the deal and the advisor noticed the problem, but the technician came up with NTF (no trouble found). So now we are out of warranty, and the problem is still intermittent but getting worse. We will get going for a ride and the driver and passenger will be set for 72 (I am in FL BTW). and after and truck comes to temp I notice the passenger started getting warm, maybe like 10 degs warmer to the driver. Then it will go ice cold and back to warm. Now the other day, the rear A/C was set to 72 and it started blowing HOT air out, but the driver side was ice cold. I don't think there is a leak because there are point were all vents will be ice cold, however the rear and passengers side have a mind of there own on keeping the temp. I had read some threads about a actuator issue, but I am thinking maybe if there is a sensor that looks at the cabin air temp might be sending wrong reading to the computer to change the actuator. Need some help, this is driving me crazy!

    Jason

  2. mmorgan1865

    mmorgan1865 New Member 1000 Posts 100 Posts

    My buddy had the same problem with his 09 Silverado and the dealer told him that they have had problems with the system and to put the truck in neutral and shut it off (while driving) and restart it to see if it clears. It worked for him but its a pain.
  3. Sandhopper

    Sandhopper New Member 100 Posts


    X2, My 04 Silverado was the same way. Same thing, drop it in "N" turn it of and start it back up it is fine. I am sorry to hear that this is still happening.

Share This Page