ECM issues

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by Landslide, Feb 14, 2011.

  1. Landslide

    Landslide New Member

    I've been having some issues lately and the only thing I can think of is it might be my ECM.The motor is new with about 1500-2000 miles on it and the TBI has been completely rebuilt, however it has started to run a little rough and sucking the fuel,more than usual,my question is I have better pistons bigger cam and performance intake manifold,could it be that my ECM needs to be recalibrated to accomodate the more powerful engine and if so does anyone know how I go about reprogramming it without costing me an arm and a leg.
     
  2. stephan

    stephan Rockstar 4 Years 5000 Posts

    If it ran good for the first 1,500-2,000 after the rebuild with the bigger cam, performance intake etc, then I don't think that's it. If the ECU or the performance parts were a problem it should have started this rough running & high fuel consumption right after the rebuild. The only thing I can think of is the fuel pressure regulator has gone off & the high fp will pour more fuel through the injectors. Rough running & higher fuel consumption can also be due to an electrical problem. Possibly a spark plug or wire breaking down. Do you have a fuel pressure guage so you can check it? AutoZone loans them out if you leave a deposit.
     
  3. Landslide

    Landslide New Member

    Thanks I'll check my fuel pressure,basically everything under the hood is new except for the ECM that's why I was wondering but I'll check the pressure.
     

Share This Page

Newest Gallery Photos