1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Electrical issue after flat bed tow

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by Willow, Aug 11, 2013.

Newest Gallery Photos

  1. Willow

    Willow Member

    Fuel pump went out in my truck (this makes number 3, first online cheap can understand- second from GM)...tried to start again before he was loaded on tow truck, battery fine. Follow truck to shop and soon as he is unloaded I jump in and try him one more time- battery almost dead and horn blows. Odd. Thought maybe key left on. Shop charged battery enough to try to do pressure test. Next day I go out after they replaced fuel filter (asked them to try that first since fuel pump was operating but low pressure and fuel filter rusted on- they guessed original). Try to start him and battery dead. They toss rapid charge on it and he cranks won't start. I have him towed home for son to replace fuel pump as I did not have $650 they quoted. Son replaced fuel pump today. He pulled fuse before installing, etc. Hooked it all back up before putting bed back on and battery dead. Hook up jumper cables from his car and when we placed positive on my truck, sparks and smoke. He double checked his connections and I checked to make sure right colors and such were matched. They were. Pulled the fuel pump fuse and tried hooking jumpers to battery cables (no battery in truck) to rule out wiring in fuel system- same issue. Truck sitting in my drive with bed half off till we figure this out. Could the tow truck driver hooked up incorrectly and pulled a wire? Its making me think there is a wire touching somewhere it should not.

    2002 chevy silverado 1500 LS 5.3 4x4
  2. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    Definately sounds like a short somewhere, as far as the tow truck driver being responsible Im not so sure.
    Did he attempt to hook jumper cables or anything like that?
    Check under the truck where he wouldve connected his chains, maybe it pinched a wire or something.
    or it could be a coincidence that on this ride you finally got a short.
    Maybe a circuit check of the fuel system is in order, could still be a possibility it has a short and this is the whole problem.
    Theres quite a few fuses that indirectly supply power to the fuel system.
  3. Willow

    Willow Member

    No, tow truck driver did not try to connect jumper cables. Just towed on flat bed. Can you tell me where exactly he would connect the chains- I have never gotten under and looked. OK...so the one relay does not cut off power to the entire fuel system?

    Oh is it normal for horn to honk itself when you try to start when battery low?
  4. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    Most drivers will wrap the chains around an axle or part of the suspension, look for resh scratches chain isnt friendly to paint.
    As far as the horn do you have some type anti theft or alarm?
  5. Willow

    Willow Member

    Will do...found that trailer hitch wiring is broken. Going to repair that, but not sure that is issue as it is broken past where son disconnected to move bed and it is still disconnected. I know that damage was done years ago by my geese and we had taped it up and apparently it came apart. Yes, the truck has an alarm you can set when you push button on key fob.
  6. Willow

    Willow Member

    The trailer wiring and a loose wire on starter was the issue. Son removed fuses and taped wires together until he can pick up a new wiring harness, but battery was able to be charged and is holding charge and starting like it should.
  7. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    Good to hear you found the problem. Sounds like youll be back to 100% in no time.

Share This Page