1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Encoder Motor and Alignment Questions

Discussion in 'GM Powertrain' started by BlackPearl, Apr 18, 2008.

  1. BlackPearl

    BlackPearl New Member

    "99 Suburban K2500 with 454.

    1) Has anyone had to replace the encoder motor on the 4wheel drive system? Mine mysteriously went out while at the dealership getting a new engine dropped in. Did yours just all of a sudden not work? How much did you pay for the new one?

    2) My alignment is off. I have had the front brakes completely replaced, pads, rotors, even the hoses, and that doesn't seem to be the cause. One dealership wanted $500 just to investigate the problem. Can you guess what I told him to do with his business card? Any ideas why the local tire shop can't dial her in?

    Thanks,

    Clutch
  2. Pete95Sierra

    Pete95Sierra New Member ROTM Winner 1000 Posts

    check your ball joints, tire camber/caster and wheel bearings. maybe replace all the bushings up front as well they are probably worn so things may be a little loose. as for the encoder motor hopefully someone can help ya out cuz i dont really know anything about that

Share This Page