1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Encoder sensor replacemente?

Discussion in 'General Chevy & GM Tech Questions' started by Mtrotter, Mar 4, 2010.

  1. Mtrotter

    Mtrotter New Member

    I searched the threads... I have an 04 Sierra Z71 with the 5.3

    I think my encoder motor is bad. I replaced the push button swtich and it acts the same...

    The truck will engage in 4wd if I turn the truck off for a min, and select 4wd hi/lo or auto
    after the truck runs for a few minutes the "service 4wd" light comes on.

    I want to try replacing the Sensor first before trying anything else. My OBDII scanner wont pull any codes on it.

    Does anyone have instructions on replacing the sensor?

    Thanks.
    Morgan Trotter
    Southern California
  2. Loggerhead Mike

    Loggerhead Mike New Member

    pull your t-case shield and front prop shaft off. 3 bolts and its out
  3. TrailLeadr

    TrailLeadr New Member 1000 Posts

    From what I get out of a bad sensor is that it will generally throw a code of C0327. If there's no code it sounds more like a bad motor.

Share This Page