Engine dies after starting

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by Trask215, Dec 6, 2008.

  1. Trask215

    Trask215 Rockstar 100 Posts

    One day my truck had the problem of when i would start it, it wouldn't stay running. I would get it started and it would die. If i gave it some throttle it would keep running but as soon as I let off it would die again. It took about 5 times before it would stay running. Any ideas? It's an '01 silverado with a 5.3L.
     
  2. raisor87

    raisor87 Rockstar 100 Posts

    replace you fuel filter
     
  3. Trask215

    Trask215 Rockstar 100 Posts

    It happened a couple weeks after I replaced my fuel filter. Thanks for the idea though.
     
  4. exceler8

    exceler8 Member

    I have a 93 that did that to me 2 times. I will share what it was on mine. I did what you did. I did a full tune-up, fuel filter, dry gas ect. One day I was leaving work, wouldnt stay running at an idle. I would have to ride the gas and brake. Then I pulled into the gas station to fill up and bam, nothing. It was the fuel pump. Then a few year later, the same problem again. It was the fuel pump. So I hope that this helps shed some light. Oh, another hint or tip. If you have more than a half a tank, I found it easier to take the bed off.....
     
  5. Trask215

    Trask215 Rockstar 100 Posts

    Alright, thanks for the insight. I replaced the fuel pump on my '98 dodge ram when I had it. We couldn't get the bed bolts loose so we pulled the full fuel tank. It wasn't too bad but would rather not do it again lol. I know i need to do a full tune-up just haven't had the time yet.
     
  6. dwill3015

    dwill3015 Epic Member 5+ Years ROTM Winner 1000 Posts

    Keep us posted.
     

Share This Page

Newest Gallery Photos