Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

engine operating with low power

Discussion in 'GM Powertrain' started by tmcroc24, Jan 3, 2010.

  1. tmcroc24

    tmcroc24 New Member

    my 07 silverado with the 5.3l v8 and 60,000 miles gave me the engine operating on low power message and shut off my stabilitrac. it wouldnt go over 2 grand or 35 mph. i had it at the dealer once for this problem and they couldnt find anything and it didnt give any codes. anyones else had or heard of this problem. also anyone know why it did this...
  2. tmcroc24

    tmcroc24 New Member

    just to make an update it happened again and now its at the dealer....
  3. unplugged

    unplugged Epic Member 5+ Years 1000 Posts

    Sounds like it is in some sort of "limp" mode. Most readers only pull active codes, but dealerships have more sophisticated equipment that can pull the history. Odd that they claimed they couldn't pull any codes. Hopefully you'll have better luck this time.
  4. tmcroc24

    tmcroc24 New Member

    just got word from dealer that there was a connection related to the pedal assembly that was corroded could that really cause this to happen

Share This Page