1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Excessive Oil Consumption

Discussion in 'General Chevy & GM Tech Questions' started by dbrannen, May 30, 2010.

  1. dbrannen

    dbrannen New Member

    I have a 2006 Silverado 1500 with 60k miles and use 1-2 quarts of oil every 3000 miles. I seem to have some dirty oil residue on my valve covers... No drips or smoke. Is this common? Should I have it checked? Thanks
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Well take a look at the rear main seal (between where the block and tranny mount incase you didnt know) and also what oil are you running?
  3. dbrannen

    dbrannen New Member

    Ok thanks. I will check it out when I get a chance.
  4. bigdaddy77084

    bigdaddy77084 Rockstar 4 Years 500 Posts

    What brand oil ya running?? 60k the motor will be dirty. If its not leaking its going out the tailpipe..(rings or leaking valve guides).
    2 quarts leaking you should see it somewhere, is the bottom of the
    truck wet with oil?...good luck
  5. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    I'd have it checked out, thats way to much oil every 3,000 miles.
  6. Silverado Junkie

    Silverado Junkie Rockstar 4 Years 500 Posts

    If its still under warranty, id take it in to the dealership.
  7. Jimbo3

    Jimbo3 Rockstar 100 Posts

    I am having the same problem... GM says normal is 1 QT every 2 thousand miles... I'm burning 1.5 QT in 3 thousand miles
  8. dsfloyd

    dsfloyd Epic Member 5+ Years ROTM Winner Gold Member 1000 Posts

    Id be worried if GM says that. If thats the case then they are making some crap motor innards. My 04 with 80k doesnt burn any oil (and I am knocking on every piece of wood I can find right now since I just wrote that:whip:).
  9. swrevin36

    swrevin36 New Member

    My 05 Avy had 141000 and never used more than .5 quarts even on 5000 between oil changes.
  10. 03 SIERRA

    03 SIERRA Rockstar

    same issue i got. ive trid thicker weights, ive tried thinner weights, and additives. What about the oil life system, do ya build up sludge, too much maybe, cause parts to leak?

Share This Page