1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Factory radio now sounds like a 70's transistor radio

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by oktillnow, Jan 11, 2014.

  1. oktillnow

    oktillnow New Member

    2008 GMC SLE, got in my truck yesterday morning turned on the radio and nothing, well almost nothing. You can hear it but there is no volumn, no bass, not much of anything. Also noticed some of the chimes aren't working either, This is the factory system.

    Any Ideas?
    Pops
  2. j cat

    j cat Rockstar 4 Years 1000 Posts

    the speakers are cheap. get a speaker you know is good and test hook up. also remove OEM speaker and see if the speaker coil is open . these coils where not made for exterior use so the coils open ..I had the same problem when my truck was just over the warranty period.
  3. Camaro69car

    Camaro69car Member 1 Year 100 Posts

    Could also be that the antenna has come loose. Check your connections / Grounds.
  4. zuki82

    zuki82 Member 100 Posts

    Yesterday I just put new speakers in my front doors! Now I have all the sucky chimes again! But I also have toons up front!! :)
  5. j cat

    j cat Rockstar 4 Years 1000 Posts

    when you buy these vehicles the speakers are an additional cost. made to fail products by gm.. they fail just before the warranty ends.
  6. oktillnow

    oktillnow New Member

    I'm not sure what the problem is or was, but the system started working properly on its on and hasn't failed again. So until the problem resurfaces, I'm not going to touch it.

    Thanks for everyone's input.
    Pops
  7. poncho62

    poncho62 Member 1 Year 100 Posts

    How cold is it there?

    I am in Canada and my work van, the radio doesnt get any sound when its real cold. Once it warms up, the sound kicks in. I figure the cold is shrinking a circuit so its not making contact. It is a Ford BTW....lol
  8. j cat

    j cat Rockstar 4 Years 1000 Posts

    that is how my speakers failed . sometimes they worked then did not. then one day the left then the right. this is a very common failure .
  9. oktillnow

    oktillnow New Member

    Well my good luck ran out, radio has quit again but its too cold here to worry about it now. Maybe when it warms up some I'll check into swapping out the speakers.


    pops

Share This Page