1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Finally installed my setup. Clicking sound from speakers? bass tuning? Suggestions?

Discussion in 'Audio, Video & Gadget Tech' started by crewxp, Oct 26, 2010.

  1. crewxp

    crewxp New Member

    I have a feeling its just an issue of settings on the amp hopefully. But I was wondering how to tune my subs. I have two 10" kickers in the back powered by a 500W Alpine amp. Bass comes from them, but I feel like the bass should be louder than it is. I have my amps settings (gain, LP, and EQ) All on the middle setting, and Gain on 3/4. I feel like people's cars ive been in with only one 10" made louder bass than my two 10"'s

    And I noticed one 'tiny' problem today though. When the radio was on, I heard a clicking sound when music was playing coming from the speakers. When I paused the cd, the clicking sound still clicked. I didn't have long to play with it, but I hope its nothing serious.

    Other than the clicking problem and bass tuning, thats it! Im glad its all finished and hope I can fix these two quirks soon.

    Any suggestions?

    Setup:
    Last edited: Oct 26, 2010
  2. SB09

    SB09 New Member

    I would suggest checking your RCA cable. Sounds like your'e picking up some sort interference, due to it being cheaply made or it is being crushed somewhere. RCA cables are one thing that should not be skimped on as far as wiring goes. It may cost you 100 instead of 20 bucks or whatever but will be worth it in the long run.
  3. randomsandwhich

    randomsandwhich Rockstar 3 Years 100 Posts

Share This Page