Flashing engine light

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by Pikey, Apr 25, 2012.

  1. Pikey

    Pikey Moderator Staff Member 3 Years ROTM Winner 1000 Posts

    Hi All,
    Every time I run my truck (2003 Yukon XL 5.3l) through the local touchless car wash The engine light flashes. I as soon as I pull out of the wash it goes off. My programer that I use to read codes shows nothing. It only happens when I do the "Works" Wash. (the longest one they have). Any ideas? I guess that I could just shut it off while in the wash and avoid the issue all together. Thanks
     
  2. pmf608

    pmf608 Epic Member 5+ Years 1000 Posts

    A flashing check engine light means that your engine is misfiring... and it should come with a code. My 2001 Silverado had a flashing check engine light until I did a bunch of maintenance on it, and that light came with a p0300 code - random/multiple misfire. So, I would check anything ignition related that the car wash could be messing with... ignition coils, spark plugs, wires, etc. and check to see if there is any way the moisture could be affecting any of those components.
     
  3. bazar01

    bazar01 Member 2 Years 100 Posts

    I will try to replicate the problem in my driveway at night by spraying some water mist on the ignition components while the engine is idling and check for a light show (sparking or arcing) that would cause the engine light to flash. How many miles? Ignition wires could be getting tired.
    Good Luck!
     
  4. moogvo

    moogvo Epic Member 5+ Years 1000 Posts

    If the car wash is blasting the bottom of your vehicle, it is likely causing a problem with the O2 sensor. It will cause the engine light to flash if it is getting a catalyst performance code too. Just an idea.
     
  5. Pikey

    Pikey Moderator Staff Member 3 Years ROTM Winner 1000 Posts

    I have tried spraying the motor down at night in the driveway. I get nothing. It has 145,000. the wires are not the original. I might have to crawl under there and spray along the exhaust area. I am leaning towards an 02 sensor issue. I can take it thru a soft cloth car was with no issue (except scratching the crap out of it). I have driven thru a few rainstorms that were so heavy people were pulling over on the freeway. The light will only turn on in that wash. I actually just left there. I shut it off this time and got no light. Next time I will put my programmer in monitor mode and watch for any crazy readings from 02 sensors, mass air flow. There are no codes stored. Thanks guys.
     
    Last edited: Apr 25, 2012

Share This Page

Newest Gallery Photos