Four Wheel Drive Problems

Discussion in 'GM Powertrain' started by bigskip83, Oct 29, 2010.

  1. bigskip83

    bigskip83 New Member

    Hello everyone, I have a 96' chevy suburban. To start with, the fwd buttons on the dash started to blink when i would try to engage the fwd. It souded like a relay under the dash was clicking struggling to engage. now the fwd lights on the buttons will not turn on and the fwd will not engage. I have had problems with my 95' tahoe before and just replaced the actuator on the front axle and it sovled the problem. I have replaced the actuator in this 96' and it had no effect "still not working". I noticed that it does have a electric vacuum switch that screws in on top of the transfer case. I am thinking this may be the problem? Of course i checked all fuses before all of this, lol. Thanks for anyones input. PS, I cant believe that chevy switched from a all steel actuator to an all plastic one in 96!!
     
  2. Z28Johnny

    Z28Johnny Rockstar

    I have a 96 Suburban and had a similar issue. The lights would blink. Now it is just stuck in 4Hi. I read somewhere that it is usually the switch that you are looking at on the front axle, although it is not a vacuum switch. I think it is some sort of temperature sensitive switch. The part is only $28 at Autozone and from what I read it is usually the issue. The problem I had TODAY when I went to install mine is that my axle switch is a 3 pin wire and all I can find from Autozone and other places is a 2 pin wire. Most of 96 had the 3 pin. Hopefully you are lucky and have the 2. I'm currently trying to find a solution. I can't be the only one on Earth that needs the 3 pin.

    I also read that there is an electric motor replacement. Again though I don't know where the 2 pin vs. 3 pin issue will play out with it. It is around $150 - $200.

    John

    ---------- Post added at 03:25 PM ---------- Previous post was at 02:14 PM ----------

    Never mind on some of what I said. The switch I thought you were talking about is the one on top of the axle... your right about the TC one being a vacuum. I ordered a new actuator to see if it fixes my problem.
     
  3. bigskip83

    bigskip83 New Member

    Thanks for the reply John. I had the same problem ordering my actuator. They sent me a 3 pin and i needed a 2 pin. I have not ordered the vacuum switch yet, but think that it is my problem. I actuator was always a problem with my 95' and when replaced would be fine for about a year. Hopfully it will fix your problem, let me know if it works for you. Has anyone ever had problems with the fwd switch itself going bad? Im still scratching my head on this one so im open to any other input. Thanks, Reid
     
  4. Z28Johnny

    Z28Johnny Rockstar

    I might have a fix for you. This morning I climbed under the Suburban, reinstalled the old 3 wire switch, installed the new actuator, checked all of the fuses, then started it up. It went back into 2wd so I wasn't stuck in 4wd, but it wouldn't switch back. I played around and noticed that it would go into 4low, but if I hit the 4hi it would go right back to 2wd. This was very depressing.

    SO.... I did some more reading and found somewhere to remove the transfer case fuse from the dash (fuse #2) for 10 minutes to let it clear any codes. I didn't have any check engine lights on so I though it would be a bunch of bs, but I tried it anyways. Removed the fuse for 10 minutes, put it back in and IT WORKED!! I shut the truck off a few times, tried hitting 2wd, 4wd, 4lo in different orders and it worked perfectly every time. Try clearing the codes by removing the fuse and see if that works.
     
    Last edited: Nov 8, 2010
  5. vncj96

    vncj96 Epic Member 5+ Years 1000 Posts

    I had to have my actual 4wd selector replaced, it can be tested so its just not a crap shoot. I have heard more about the selector going bad then anything else on these particular trucks.
     

Share This Page

Newest Gallery Photos