1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Front Diff problem

Discussion in 'GM Powertrain' started by jnbascom, Dec 14, 2009.

  1. jnbascom

    jnbascom New Member

    Okay folks, there a lot of threads on this issue but I am getting more confused by the minute. I have a 1999 GMC Jimmy with the push button 4X4 (4 button). When I press the buttons everything works correctly except the front diff wont engage. The transfer case is working properly and the drive shaft is turning. There is a cable running to the diff then under the batt tray. The cable moves freely but there is no vacuum going to the diaphram. Tracing the lines back there is a switch on the fire wall but no vacuum to it either. Where do I go from here?

    Don't know if this helps but my selector switch for the heater/AC controls won't work either. just blows out all the vents. I have been reading about a vacuum line on the back of the motor near the distributer that controls both the 4X4 and the heat/AC controls. Could this be the problem? I have a vacuum line that goes no where and wondering if this "T" near the dist is where it should go.
    Last edited: Dec 14, 2009
  2. brianj

    brianj Rockstar

    I would say you are losing vacuum somewhere, and it sounds like you have found the spot.That would explain both problems.
  3. jnbascom

    jnbascom New Member

    Hooked up the vacuum line. 4X4 worked good for 2 tries and now it is stuck in 4X4 auto. I disconnected the vacuum line and it still is stuck in auto on the dash but the diff disconnected itself. What happened to cause this?

Share This Page