front differential noise

Discussion in 'General Chevy & GM Tech Questions' started by dshewy14, Feb 17, 2010.

  1. dshewy14

    dshewy14 Rockstar 100 Posts

    so ive noticed a noise in the front end. and other day i put a hub assembly on it and that didnt fix it so the other day, i took a test drive the other day after that and i put it in 4wd. when ii went to take off it started making the most horrible noise(popping, grinding, roaring) and it was pulling super hard to the right and it like pulled me to a stop .that was in 4H. so after i got back to where i was going i tried putting it in auto 4wd. it did the same thing then put it back in 2wd and went back to alright. anyone ever had the same problem. im leaning towards something wrong in the front differential, but dont know what.
     
  2. Jimmiee

    Jimmiee Epic Member 5+ Years 1000 Posts

    I would drain the oil and see if there's any metal in the differential. It sounds like you have a problem inside the diff.
     
  3. dshewy14

    dshewy14 Rockstar 100 Posts

    yeah thats what im fiigureing but idk what it could be. never had to mess with the froont dif. and know nothin about it
     
  4. Gambit

    Gambit Rockstar 100 Posts

    Check the CV Shafts i had this happen on my 89 (IFS) and it turned out that i had a torn boot onthe CV shaft which let crap bild up inside and screwed it up. Replaced CV shaft and all was well. Not saying this is your problem just something easier to check.
     
  5. dshewy14

    dshewy14 Rockstar 100 Posts

    i checked them out other day when i changed me hub out but i didnt find nothinin wrong so idk
     
  6. Loggerhead Mike

    Loggerhead Mike Rockstar 100 Posts

    double check everything you did in that hub area if it wasnt pulling hard right before you replaced it

    get that thing in the air eather jackstands or a lift so you can get under it and see whats going on while the wheels are spinning
     
    Last edited: Feb 18, 2010
  7. dshewy14

    dshewy14 Rockstar 100 Posts

    well i changed the front end fluid and drove it down the road a lil and wormed it up and beleve it or not didnt make much noise and didnt pull at all. i couldnt believe it so hopefully it will be ok now.
     
  8. dshewy14

    dshewy14 Rockstar 100 Posts

    I drove it for about an hr today and got it good and warmed up and the noise is still there when not it 4wd but ever thing is seems ok
     
  9. dshewy14

    dshewy14 Rockstar 100 Posts

    well figured id fill youll in on what i found out. i took it to the shop today and they told me they believe it the carrier bearings in the front differential. anyone ever had a problem with them?
     
  10. ndfan

    ndfan New Member

    I just had the front diff rebuilt in my 99 burb,bearings were bad,caught it before the races were destroyed. cost to have it rebuilt @ my local garage was 600.00 total
     

Share This Page

Newest Gallery Photos