Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Fuel Guage bouncing around......

Discussion in 'Audio, Video & Gadget Tech' started by iceman68, Mar 18, 2009.

  1. iceman68

    iceman68 New Member

    Just bought a 2000 Silverado... very clean truck, low milage.... all is well except that the fuel guage does not seem to work consistently. When I start the truck, the guage shows empty, the "Low Fuel" indicator lights up in the dash and as I'm driving down the road, the guage starts working on and off...

    Anyone have this problem? Is it the sending unit in the tank? or an electrical issue under the dash? Any thoughts would be appreciated!!!
  2. kaiah723

    kaiah723 Rockstar

    is the fuel pump huming loudly. the sending unit for the guage is in the tank. i had a blazer and the guage bounced back and forth from full to empty, a year later the fuel pump went.
  3. iceman68

    iceman68 New Member

    I do hear a little whine from the back of the truck...but nothing major - thought this was normal.
  4. kaiah723

    kaiah723 Rockstar

    a little whine is normal but if it starts getting louder it means the pump is going. mine could be herd over the engine right before it went.
  5. 04blackz71

    04blackz71 Rockstar 100 Posts

    i have an 04 1500 and its not the fuel gauge its the oil pressure gauge
  6. iceman68

    iceman68 New Member

    So when you changed the fuel pump, did the guage work properly?
  7. kaiah723

    kaiah723 Rockstar

    yup, i was happy as hell to because i ran out of gas 3 times when the guage was broke and that blazer was heavy as hell to push to the gas station
  8. etpn13

    etpn13 Member

    my dad's 01 fuel gauge has been doin the same thing for years. i just recently bought an 01 and the fuel gauge was also like that and i noticed before i bought it and also the check engine light came on before i signed all the paperwork so i made the dealership fix it before i signed the rest of the paperwork and they said that it was a sensor that made the fuel gauge funky and the check engine light come on. it seemed like it was a relatively easy fix since they i took it there at like 3 one day and it was ready by noon the next and they also replaced the fog light in the this time and this dealership didnt seem to know their heads from their butts b/c it took 2 weeks and 7 trips to the dealership for me to get everything finalized.
  9. Z71_guy

    Z71_guy Epic Member 5+ Years 1000 Posts

    i would have to say the sending unit is bad, but as stated earlier its part of the pump assembly
  10. jim1958

    jim1958 Member

    I would have to say Check the the ground , usually the guage fails to read properly due to a bad ground.

Share This Page