Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Fuel pump problems

Discussion in 'Performance & Fuel' started by tgibson12, Jul 16, 2008.

  1. tgibson12

    tgibson12 New Member

    i just got done rebuilding my engine on my 1994 silverado k1500 not to long ago and when it was ready to start her up that didnt happen. The truck would crank but not start. So we bought a new battery made sure there was gas still nothing. We disconected the fuel lines to the throttle body to see if it was getting gas and it wasnt so then we dissconnected it from the fuel filter to iff if it might be clogged, turns out it wasnt. The fuel pump isnt even pumping gas, i never touched the gas tank or anything so im stumped. i am hoping i dont have to buy a new fuel pump. I know on some fords there is a reset switch behind the kick panal and i was wondering if there was anything like that on my truck, that i have to reset? A friend gave me the idea to run a wire straight from the battery to the pump but im a little hessitant on that. Everything worls fine it just doesnt pump gas.


    any ideas would greatly help me out.

    thanks tyler.
  2. GaryL

    GaryL Epic Member 5+ Years ROTM Winner 1000 Posts Platinum Contributor

    Check your fuel pump relay before you get too far into tearing it apart.

    Have you tried pouring gas in the throttle body to see if it will start on that?
  3. tgibson12

    tgibson12 New Member

    yeah ive tried that and when i do it seems to need more gas.


    where is the relay located? under the hood?
  4. raisor87

    raisor87 Rockstar 100 Posts

    Is your truck equipped with any kind of factory anti theft devices? You may try holding the key forward in the ACC on position for 10 minutes and then turning it off and then trying to start it. I had this problem on a 2000 chevy malibu, replaced every thing under the sun (battery, fuel pump, relays, filters) and determined it was the ignition. After talking to a dealership service center manager for an hour he reluctantly told me this tip to reset the anti theft
  5. Rumpamuro

    Rumpamuro Rockstar 100 Posts

    i coulda sworn i posted something in this thread not too long ago. Check the inline fuse grey wire from the relay goes and splices to the fuel pump oil pressure switch, then to a inline fuse, then to splices once more, one to the fuel pump one to the ecm.

Share This Page