Gas guage on 05 trailblazer

Discussion in 'Games Forum' started by pacman12, May 29, 2011.

  1. pacman12

    pacman12 New Member

    on my 05 trail blazer the gas guage is broken i heard that this a problem in alot models is thier a cheap fix im considering putting techron in the tank to clean sulfur deposits on the float is there any thing else i could do besides taking it to a mechanic
     
  2. TELORVEHC

    TELORVEHC Rockstar 4 Years 1000 Posts

    It's most likely your gauge cluster, not the float. Does your gas gauge not work at all or does the needle itself move around?
     
  3. Crispyt

    Crispyt Rockstar 100 Posts

    Could be a bad sending unit as well
     
  4. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    Welcome to the club, pacman12.
     
  5. stephan

    stephan Rockstar 4 Years 5000 Posts

    Welcome to the club Pacman. X2 on the guage being the culprit rather than the sending unit. The tank units very seldom give any trouble. I don't know of any easy fixes.
     
  6. clgoch187

    clgoch187 Rockstar 4 Years 500 Posts

    why is this in the haha part of the forum?
     
  7. Coach24

    Coach24 Rockstar 3 Years 5000 Posts

    Was the question ever resolved? If so, will you share the resolution?
     
  8. SurrealOne

    SurrealOne Former Member ROTM Winner 1000 Posts

    Got a trailblazer you're trying to fix, Coach? Some other gas gauge problem?
     
  9. Coach24

    Coach24 Rockstar 3 Years 5000 Posts

    Just interested in the resolution of this issue. Never know when these answers might come in handy
     
  10. SurrealOne

    SurrealOne Former Member ROTM Winner 1000 Posts

    Uh huh. :neutral:
     

Share This Page

Newest Gallery Photos