1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Grinding Noise In Transfer Case

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by CMXIII, Jul 6, 2007.

  1. CMXIII

    CMXIII New Member

    I have 00 Silverado with the Auto-Trac T/C. The service 4wd light came on however when it came on it only resulted in the inabilty to transfer out of whatever mode i was in (2hi/4hi/4lo/auto) and as soon as i turned off the truck it would go off. One day i was driving the truck on auto mode and it started grinding but it stopped after i switched to 2hi. Now everytime that i drive in auto mode at speeds above 55mph it grinds only when i press or depress the accelerator pedal. Any one have any clue??
  2. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    Sounds like a bearing going out. Have you changed the fuid since the noise/problems started? The original light could be to tell you theres to much metal on the sensors. If not I'd recommend changing the fluid and screening it to see how many metal particles you have. My guess is a lot. Unfortunately transfer case problems dont diagnose well, they usually have to be opened up to find problems.
  3. CMXIII

    CMXIII New Member

    I changed the fluid before the light came on. However, it still came on several times and it does not register a code on the ECM. I changed it 4000 miles after. It still comes on everynow and then.

Share This Page