HARD knock at start

Discussion in 'GM Powertrain' started by dpeter, Nov 6, 2010.

  1. dpeter

    dpeter Rockstar 4 Years 500 Posts

    This new to me 2000 5.3L Yukon has a moderate to severe knock at start. This is not a no oil pressure knock or a loose engine type of noise. It sounds like spark knock or realy advanced timing just at the initial start (when turning key) and lasts for maybe one revolution. Maybe for four or five hard hits then smoothes out and runs fine. It has no check engine lights on or any other indications of problems.
    Thought maybe carbon buildup and trying the seafoam treatment but before I do someting unneccessary or foolish that I would seek more informed ideas.
    Thanks, Doug
     
    Last edited: Nov 6, 2010
  2. phoebeisis

    phoebeisis Epic Member 5+ Years 1000 Posts

    The early 5.3's are famous for a "piston slap" type noise.
    I've read that it has something to do with carbon buildup above the top ring(not exactly sure why that would cause a noise-maybe the piston is canted a bit at first and it rocks back and forth hitting the carbon on the cyl??)

    Others -more knowledgeable will chime in.
    I'm surprised it is so short lasting- is it worse in the cold weather?
    Charlie
     
  3. dpeter

    dpeter Rockstar 4 Years 500 Posts

    Thanks for the reply pheobeisis. I do believe I have some of that piston slap but it is mild and as you suggest it is prominent when cold and lasts for maybe five minutes at most or untill it warms a bit. The noise I am concerned with sounds like premature detonation and it is disturbingly loud and shakes the motor. it does this at every start cold or warm. The family has a history of GM products and none have started as this one does.
     

Share This Page

Newest Gallery Photos