Has this ever happened to anyone

Discussion in 'General Chevy & GM Tech Questions' started by rod, Jun 17, 2008.

  1. rod

    rod New Member

    2003 GMC Yukon with 100,000 has always run like a charm with normal service. Even in the cold winter I could turn the ign. switch to start release and truck would start after turning over 2 or 3 times. The other day in Memphis 95 deg. weather turned ign. switch to start realeased truck turned over 5 or 6 times and no start hit the starter and truck cranked up no problem. Next morning no start after turning over 7 or so times and releasing key it would only diesel for a few seconds. Any Ideas, Thanks
     
  2. collinsperformance

    collinsperformance Epic Member 5+ Years 500 Posts

    this can be many different things. fuel pump, fuel regulator, IAC or any other possibility Battery, cables. you might see if there are any stored codes and or the year the battery was installed.....mike
     
  3. Pete95Sierra

    Pete95Sierra Epic Member 5+ Years ROTM Winner 1000 Posts

    i would recommend checking your battery terminals and cables. clean them up nicely and get any corrosion off and retighten down your cables. you may have a lose connection with your fuel pump as well and it may not be coming on.
     
  4. GaryL

    GaryL Epic Member 5+ Years ROTM Winner 1000 Posts Platinum Contributor

    Have you changed the plugs, fuel and air filters? May be some dirty injectors, you might try a can of Sea Foam.
     
  5. jeffj87

    jeffj87 New Member

    It could be a couple different things. It may be starving for fuel, need to change filter, or water in gas. New cap and rotor, and plugs and wires wont hurt anything either.
     

Share This Page

Newest Gallery Photos