1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Heated seat does not work

Discussion in 'General Chevy & GM Tech Questions' started by kguygm, Dec 29, 2009.

  1. kguygm

    kguygm New Member

    Dear Sirs,
    My 1999 K1500 suburban has driver and passenger side heated seats. These are not working and I wanted to ask what the most common problem for this is? Are they easy to fix?

    Thx in advance

    kguygm
    Last edited: Dec 29, 2009
  2. sruss

    sruss New Member

    ok, and add that your cigarette lighter keeps blowing fuses too. Get a wiring diagram off the net, there has to be a relay that isn't working right. Sounds like its stuck open allowing any amount of amps to flow through. Your fuse is working, its doing its job.
  3. vncj96

    vncj96 New Member 1000 Posts

    I have the same problem on the same year of suburban, neither of them worked at all last year and now this winter the passenger side works part of the time and still no driver. I had to pull off the drivers seat for another reason, and checked all my connectors and exposed wires and everything appeared just fine (nothing loose and no cracks/deterioration of the wires) but ther is a sown piece of fabric underneath that feels like it holds a couple of relays so that is my guess, that they are bad, but really have no way to test them, nor do i want to go through the pain of taking the leather off the seats to physically inpsect the heater pad and the rest of the wiring. With 11 years of in and out and on and off, my guess is the relay is shot or the heater element has broken wiring in it and would need to be replaced

Share This Page