Heater/Ac blower problem

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by Zoner, Mar 21, 2007.

  1. Zoner

    Zoner New Member

    Hey folks got a problem with my 04 Silverado.
    Blower motor quit. Resistor plug was melted so I replaced the resistor. Still nothing. I've got juice into the resistor but nothing after it or on any other terminals on the plug. Any ideas?
     
  2. Cableguy

    Cableguy Epic Member 5+ Years ROTM Winner 1000 Posts

    Hey Zoner, Welcome to the site. Is your 04 not under warranty?
     
  3. Zoner

    Zoner New Member

    Just ran out. Ain't it always that way?
     
  4. Cableguy

    Cableguy Epic Member 5+ Years ROTM Winner 1000 Posts

    You'll have to forgive me. I'm not savy on the newer style silverado...but I'm not diggin' the melted wire thing. sounds like a good short somewhere. Have you tested blower motor itself?
     
  5. Zoner

    Zoner New Member

    Not yet. Blower was working fine before this all started.
    When it wouldn't work you had to rattle the plug at the resistor/relay.
    I just assumed the plug was dirty or corroded. Then found the melted ground post when I went to clean it.
    Will check blower motor now also.
    I'm still not getting any voltage at the resistor plug other than main feed.
    Is there another fuse in the cicuit other than "blower"?
     
  6. Cableguy

    Cableguy Epic Member 5+ Years ROTM Winner 1000 Posts

    Then you might need control head unit in dash. I just replaced that in my work van (I lost 1/2/3 position on heater setting) then when I lost high I almost froze to death at work. :he: To my knowledge there is control head/relay/motor thats all you have to work with. Good luck, let us know what you find.
     

Share This Page

Newest Gallery Photos